Top Menu

subcategories prefix with hyphen in excel

20 Oct 2015 06:50 - 20 Oct 2015 06:51 #344 by james dumar
Hi there, when i export csv, product subcategories prefix with a hyphen which excel sees as a minus sign operator, thus the subcategories read as #NAME?.
Can you tell me how to fix this please?

version excel-like 1.1.29

This is from my work, so if we need a new version let me know and i will hit up the boss.
Kind of urgent for me :-)

Thanks!
20 Oct 2015 07:35 - 20 Oct 2015 07:36 #345 by Super User
Well if name is '#NAME' then it would be incorrect to change that to 'NAME'.

I suppose we can tell you where to change code to so '#NAME' exports to '@NAME' and '@NAME' imports to '#NAME' for example. So some sore of character replacement. Will this suit you ?

It this joomla/VM or WP/Woo ?
The following user(s) said Thank You: james dumar
20 Oct 2015 07:39 - 20 Oct 2015 07:41 #346 by james dumar
Thanks for the quick reply!
It is on Joomla.
If this item is fixed on the latest version will be happy to purchase!
It is caused by =-name ( of sub category)
main categories work fine
20 Oct 2015 08:02 - 20 Oct 2015 08:03 #347 by Super User
Can you send me exported CSV so I can see

(send it via email)

Best Regards,
The following user(s) said Thank You: james dumar
20 Oct 2015 08:14 #348 by james dumar
done
20 Oct 2015 08:17 #349 by Super User
Nothing I received jet. Try to zip it and change .zip to .zi_

Or try to attache it here and I will delete it as soon I download it.
20 Oct 2015 08:21 #351 by Super User
Ok I got it via email.

In CSV itself it is '#NAME?'.

Can we get access to site so we can have a look?
The following user(s) said Thank You: james dumar
20 Oct 2015 08:43 #352 by Super User
Ok , just update (Extension manager) . This version uses - , newer use /
The following user(s) said Thank You: james dumar
20 Oct 2015 08:50 #353 by james dumar
Wow!
Works like a charm!
Thanks so much!
20 Oct 2015 08:53 #354 by james dumar
will definitely recommend this any chance i have.
21 Oct 2015 05:05 - 21 Oct 2015 07:10 #355 by james dumar
the prices multiply when i enter them through the application interface, ie; 12.36 becomes 1236 with no decimal.
any idea of a fix?
also, category uploads not working from csv
21 Oct 2015 13:34 #357 by Super User
Maybe you activated German numbers format
Time to create page: 0.069 seconds